Search found 391 matches

by trinidude4
Sat Apr 25, 2009 11:26 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

RedShadow wrote:@Trinidude: I think those mediafire links are broken...


I think mediafire is down. If it doesn't come up again soon, I'll upload them somewhere else.

--Edit--

Nevermind...mediafire is working. I just tried the links and they worked.
by trinidude4
Sat Apr 25, 2009 1:17 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Hi, i need help. I downloaded beta 3.120 (both performance and w/ shaders) and didn't worked on my mac. Do you already know this fact? Are you using Tiger? If you are, I'm aware. If not, let me know what type of Mac you are using. Mac users on Tiger: Can you please try replacing your Python.framewo...
by trinidude4
Fri Apr 24, 2009 7:55 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Yeah, I tried it too! I think it was the same problem, I can post the error if you want, Just wait a sec... ---- EDIT ---- Link (dyld) error: Symbol not found: _pthread_cond_init$UNIX2003 Referenced from: /Users/powermac/Desktop/Frets on Fire.app/Contents/Frameworks/Python.framework/Versions/2.6/Py...
by trinidude4
Fri Apr 24, 2009 7:23 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

RedShadow wrote:Mmm, Sorry to hear that, I wish you good luck man, Mac users count on you :wink:


Just wondering, have you tried the python2.6 version? I don't know if I have to fix that one too.

I think I found the problem in the python2.5 version though.
by trinidude4
Fri Apr 24, 2009 7:16 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Link (dyld) error: Symbol not found: _pthread_cond_init$UNIX2003 Referenced from: /Users/powermac/Desktop/Frets on Fire.1.app/Contents/Frameworks/Python.framework/Versions/2.5/Python Expected in: /usr/lib/libSystem.B.dylib Aww man, not again. It's a problem on my end and I'll try figuring it out. T...
by trinidude4
Wed Apr 22, 2009 5:45 am
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

I recompiled the Mac 3.120 beta 1 binaries. Here are the links:
Python 2.6 with Py-OpenGL 3 http://www.mediafire.com/?rm2k5kidzng
Python 2.5 with Py-OpenGL 2 http://www.mediafire.com/?ye2zufnk4mf
by trinidude4
Tue Apr 21, 2009 10:41 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Alright well thanks for your help. No rush. I know you've got plenty of stuff on your plate. Ok, I hope I made a quick workaround for the python2.6 version. 1. Download this file and extract: http://www.mediafire.com/?jyi3dzr5hzo 2. Replace the libSDL_mixer file in the Frameworks folder in the Fret...
by trinidude4
Tue Apr 21, 2009 10:15 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

How do I disable pitchbend if I can't get FoFiX to load? I changed whammy_fx from 1 to 0 in fretsonfire.ini but it didn't help any. Change whammy_effect to 0 in fofix.ini. It's still giving me the same error after changing whammy_effect to 0 in fofix.ini. It's the fofix.ini located in Frets on Fire...
by trinidude4
Tue Apr 21, 2009 9:25 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

bbombf wrote:How do I disable pitchbend if I can't get FoFiX to load? I changed whammy_fx from 1 to 0 in fretsonfire.ini but it didn't help any.


Change whammy_effect to 0 in fofix.ini.
by trinidude4
Tue Apr 21, 2009 7:55 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

When running either of trinidude2's 3.120beta packages, I get this error: error: Failed loading /opt/local/lib/libvorbisfile.dylib: dlopen(/opt/local/lib/libvorbisfile.dylib, 2): image not found I'm running 10.5.6 and the regular 3.100 package works fine. I assume I'm just missing something that I ...
by trinidude4
Sun Apr 19, 2009 11:41 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Any Mac users who want to try out the 3.120 beta 1: Python 2.5 + Py-OpenGL 2: http://www.mediafire.com/?fv1jzxmmzyg Python 2.6 + Py-OpenGL 3: http://www.mediafire.com/?020tmjyzzmd Try the python 2.6 version first. It runs smoothly on my Macbook (second generation white macbook with GMA 950 graphics)...
by trinidude4
Sun Apr 19, 2009 4:38 pm
Forum: Tech Support
Topic: Wiitar and Whammy Bar
Replies: 4
Views: 572

Re: Wiitar and Whammy Bar

The Mac packages have the pitchbend module included. I think the problem is with DarwiinRemote. I don't think the game recognizes the analog whammy if you are using DarwiinRemote, but I'm not too sure about that. I've been using Wiitar and I had to assign a key to the whammy bar just to use it as a ...
by trinidude4
Sun Apr 19, 2009 2:39 pm
Forum: FoFiX
Topic: Guitar Hero III Theme -=[For FoFiX]=-
Replies: 909
Views: 354046

Re: Guitar Hero III Theme 3.20 -=[For FoFiX 3.10+]=-

Matrixist wrote:I have the newest version downloaded...how do I install it to the game?
On a mac**


Copy the theme into Frets on Fire.app/Contents/Resources/data/themes and select the Theme in Display Settings.
by trinidude4
Sat Apr 18, 2009 2:25 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

Actually, running from source on a Mac is almost exactly the same as running from source on linux. Open Terminal.app, cd to the source directory, and execute python FretsOnFire.py (or "python2.5 FretsOnFire.py" or "python2.6 FretsOnFire.py" depending on what python you have insta...
by trinidude4
Thu Apr 16, 2009 6:07 pm
Forum: FoFiX
Topic: FoFiX v3.1xx development thread
Replies: 3609
Views: 374339

Re: FoFiX v3.1xx development thread

I was playing around with different combinations of python on my Mac to see how the frames per second compare to each other. Both python 2.5 and python 2.6 with py-opengl 3 give me a pretty steady 50 fps. Something I didn't expect though is that binaries that included psyco dropped my fps to about 4...

Go to advanced search